[Microsoft Excel] copiare solo le celle pari o dispari

 

Immaginate di avere una serie di dati elencati in una colonna e di avere la necessità di copiare solo quelli nelle celle pari in un’altra zona del foglio.

Si può risolvere il problema utilizzando le funzioni Indice() e Rif.Riga() in questo modo:

=INDICE(Intervallo;RIF.RIGA()*2)

Ad esempio: provate ad inserire una serie di dati elencati nella colonna A di un foglio di Excel, supponiamo dalla cella A1 alla cella A30.

Se dovete copiare i dati delle celle pari (A2, A4, A6…) nella colonna B dovrete inserire nella cella B1 la seguente formula:

=INDICE(1:30;RIF.RIGA()*2), trascinandola poi fino alla cella B15.

Se desiderate poi elencare i dati delle celle dispari della colonna A (A1, A3, A5…) nella colonna C allora (nella cella C1) scrivete la seguente formula:

=INDICE(1:30;RIF.RIGA()*2-1) e trascinatela fino alla cella C15.

 

Questa voce è stata pubblicata in Trucchi e Consigli per il Pc. Contrassegna il permalink.

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...